DHL Versenden: Disruption of service
Incident Report for shipcloud
Resolved
The DHL Versenden webservices have recovered.
Posted May 20, 2020 - 15:42 CEST
Monitoring
The DHL Versenden webservices are currently running slow or into timeouts. We're monitoring the situation.
Posted May 20, 2020 - 15:09 CEST
This incident affected: Carrier APIs (DHL).