DPD services: Slow response times
Incident Report for shipcloud
Resolved
The DPD services are back to normal.
Posted 19 days ago. Apr 03, 2019 - 09:20 CEST
Monitoring
The DPD services currently have slow response times. Please be patient. We're keeping you update.
Posted 23 days ago. Mar 29, 2019 - 19:27 CET
This incident affected: Carrier APIs (DPD).