DHL returns: Temporary disruptions
Incident Report for shipcloud
Resolved
The DHL returns service is back to normal.
Posted Nov 06, 2017 - 19:34 CET
Monitoring
The DHL returns service is slow from time to time. We're monitoring the situation.
Posted Nov 06, 2017 - 12:33 CET