DPD: Disruption of service
Incident Report for shipcloud
Resolved
This incident has been resolved.
Posted Apr 15, 2020 - 19:30 CEST
Identified
The DPD webservices are currently running into timeouts. We're monitoring the situation.
Posted Apr 02, 2020 - 14:47 CEST
This incident affected: Carrier APIs (DPD).