DHL Returns partial outage

Incident Report for shipcloud

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 14:26 CEST

Identified

We are currently observing limited availability of DHL Returns functionality and are actively investigating.
Posted Jun 02, 2026 - 13:37 CEST
This incident affected: Carrier APIs (DHL).