DHL Tracking API returns empty status details
Incident Report for shipcloud
Resolved
Looks like DHL was finally able to fix the issue. Most of the Tracking API responses are back to normal and shipment status should update in the next hours.
Posted Jul 03, 2020 - 16:22 CEST
Monitoring
Tracking has been reactivate and we are monitoring the results.
We will keep the incident open until DHL has fixed the root cause.
Posted Jul 01, 2020 - 16:30 CEST
Update
A fix to ignore the empty status updates form the DHL tracking API has been deployed.
We are currently removing the existing empty tracking events and once the process is complete we will reactivate the tracking.
Posted Jul 01, 2020 - 15:41 CEST
Update
We are continuing to work on a solution to ignore the empty tracking status updates.. To prevent further empty tracking updates from being created, we have temporarily disabled tracking.
Posted Jul 01, 2020 - 14:01 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 01, 2020 - 10:06 CEST
Identified
The DHL Tracking API is currently returning a lot of status updates that contain no data except for a timestamp which almost always is an update for the corresponding shipment. This effect causes our platform to send out tracking updates.

DHL is aware of the problem and is working on a solution.
Posted Jul 01, 2020 - 10:05 CEST
This incident affected: Carrier APIs (DHL).