shipcloud app and API performance

Incident Report for shipcloud

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 12:35 CEST

Update

We are continuing to investigate the issue. Shipments with the carrier UPS are currently running into errors
Posted Jul 09, 2025 - 12:20 CEST

Investigating

We are investigating reports of degraded performance.
Posted Jul 09, 2025 - 12:02 CEST
This incident affected: API (api.shipcloud.io) and WebUI (app.shipcloud.io).