GLS: Disruption of service

Incident Report for shipcloud

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 11:12 CEST

Monitoring

The GLS services are currently slow and/or running into timeouts.
Posted Jun 23, 2025 - 09:22 CEST
This incident affected: Carrier APIs (GLS).