DHL disruption of service
Incident Report for shipcloud
Resolved
The DHL services are back to normal
Posted Nov 30, 2018 - 13:30 CET
Monitoring
The DHL service for creating shipping labels is currently responding with errors.
Posted Nov 30, 2018 - 12:30 CET
This incident affected: Carrier APIs (DHL).