Deutsche Post: Disruption of service
Incident Report for shipcloud
Resolved
The services are back to normal
Posted Apr 22, 2020 - 08:26 CEST
Monitoring
The Deutsche Post services are currently slow/running into timeouts. Please be patient. We will keep you updated
Posted Apr 22, 2020 - 08:02 CEST
This incident affected: Carrier APIs (DPAG).