UPS disruption of service

Incident Report for shipcloud

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 08:33 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 28, 2026 - 08:22 CEST
This incident affected: Carrier APIs (UPS).