DHL PL unreachable
Incident Report for shipcloud
Resolved
This incident has been resolved.
Posted Nov 09, 2022 - 13:23 CET
Investigating
The Carriers Services and Website are currently unreachable
Posted Nov 09, 2022 - 10:00 CET
This incident affected: Carrier APIs (DHL PL).