UPS: Disruption of Service

Incident Report for shipcloud

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 09:45 CEST

Investigating

We are currently investigating this issue.
Posted Apr 26, 2026 - 22:00 CEST
This incident affected: Carrier APIs (UPS).